Complete Guide on Cisco Router Configuration | Beginners Tutorial

Cisco Router Configuration

Complete Guide on Cisco Router Configuration For Beginners

This article is a complete Guide on Cisco Router Configuration with Details. I have divided this article into three parts i.e.

I want to make it clear that this cisco configuration tutorial is for cisco learners. Although I have tried to cover the most topics, but visit Cisco’s website for more details and advance configuration.

In basic Cisco router configurations, we will review all basic steps for configuration of a router and then see all basic Cisco CLI commands. 

Basic Cisco router Configuration step by step

In Order to configure a cisco router you need to access the router CLI interface. You can do this in numerous ways. Here I am show you the most basic way to access a cisco router that is access Cisco router through console cable. Most for configuring a brand new router you need to adopt this method.

Access Cisco router with USB Console cable

Old console connection came with the DB-9 to console connection. But now a USB console connections are being used in market. You see this connection in following figure and you can connect it according to this.

Router Console port

Once your connection setting is complete, you are required a software for access the router CLI. Putty is the most famous and easy to use software. You can download it free from internet. For making the connection to your router you need to confirm the com-port number, open device manage and find the com port number under the “Ports (COM & LPT)”. Open the putty and give the same serial line as you find in device manage and click connect.

putty setting

You can use any other software for creating a connection to router.

What are Three Modes in Cisco Router configuration?

Once you have a physical connection with your Cisco Router, you can configure it. Before Going into configurations of Cisco Router, let introduce you the basic configuration modes of Cisco. There are 3 modes or command-levels in Cisco router. In each command mode you have specific privileges and control.

  1. User Mode
  2. Privileged EXEC Mode
  3. Global_Configuration Mode

Cisco Command mode

Cisco User Mode Cisco:

In first command mode of cisco you can run limited type of show commands, basic reachability tests. This command mode is represented by symbol “>”.

Cisco Privileged Mode

Privileged EXEC is second command level mode with the symbol “#”. Use “enable” command in user mode for accessing the privileged mode. In this mode you can have access to all monitoring commands of router.

What is global configuration mode of cisco router?     

The Global configuration mode is for administrator where you can configure your Cisco router and the running configuration. You can access global configuration mode from Privileged EXEC mode using a command “configure terminal”. For more Cisco Global configuration mode Commands you can visit here.

How to Check Current Configurations on Cisco Router?   

Once your cisco router is boot up you can check already performed configuration or default configuration Using command show running-config. If you are new to cisco just run this command in privileged mode this will give you a brief of all physical interfaces of cisco routers as well as all the protocols configuration.

What are Different types of passwords you can set on CISCO Router?

You can set different types of password on each command level mode, which will make your router secure.

How to configure console Password on Cisco Router?

The most basic password that you can configure on cisco router is to set the console password. This password blocks the unauthorized access through console cable on Cisco router. You can set the console password by using the following commands.

Router2>enable
Router2# configure terminal
Router2(config)#line console 0
Router2(config-line)#password cisco
Router2(config-line)#login

Above command will set the console password of router to “cisco”.

How to set enable password?

With the enable password you can secure privilege exec mode. You can set enable password in two ways. Both commands will set the enable password but the difference is first command will save the password in clear text which will be visible in show running-config, whereas the enable secret will save the password in encrypted form.

router(config)# enable password cisco
or
router(config)# enable secret cisco

How to set the Telnet password on Cisco Router?

Telnet password is used to secure your remote access to cisco router. By default there are five VTY line ot connections available but it may vary depending upon the version of Cisco router. You can set the telnet password by using these commands:

Router(config)#line vty 0
Router(config-line)#password cisco 
              (This command will Set password to cisco on five vty lines)
Router(config-line)#login

How to configure Cisco Router Host name?

After securing your router with different password, the most basic setting is to change the router name or host name of your cisco router. You can accomplish this by executing a cisco command “Hostname <router_new_name> in global configuration mode.

Router(config)# hostname home_router
home_router(config)#

Above command will set the hostname to “home_router”

Disable automatic domain lookup

If you are beginner then it is better to turn off automatic domain lookup. It will save your time because if domain lookup is not disabled then router tries to resolve every word that is not a command. And every incorrectly typed command will result a wait of one or two minute. To understand the concept of automatic domain lookup any random word on cisco router and press enter and see the results. You can disable it with the help of command:

Router(config)# no ip domain-lookup

Configure IP address of Cisco Router

Configuring an IP address of a Cisco router is a most common and easy task. You can setting the IP address to any router interface with the following details

  • Choose the interface by number.
  • Specify the interface number.
  • Specify the IP address and Subnet mask

You can check all the interfaces of a router by using the command “show ip interface brief” this will display all the interfaces of your Cisco router. Now select interface you want to configure. There are different type of interfaces available in Cisco router e.g. Ethernet, fastethernet, serial interfaces etc

You can configure all type of interface in a same way. Following commands can be used for configuring the Cisco router interfaces

Router(config)# Interface <interface_type & number>
Router(config-if)#ip address <IP_Address of interface> <Subnet Mask>
Router(config-if)#no shutdown

Following are the examples of different interfaces configurations on Cisco router:

 

Sr FastEthernet Interface Serial Interface
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 10.1.0.1 255.255.0.0
Router(config-if)#no shutdown
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 10.1.0.1 255.255.0.0
Router(config-if)#clock rate 64000
DCE side only command. Assigns a clock rate for the interfaceRouter(config-if)#bandwidth 64
Router(config-if)#no shutdow
n

What is a loopback interface used for & how to Configure it?

The Loopback interfaces are not physical interface but these are the logical interfaces used for different purpose. Loopback interface remain always up and most network professional use these interfaces for testing to test IP software without worrying about broken or corrupted drivers or hardware. A different IP scheme is designated for loopback IP  address with start number 127.0.0.1.  You can configure the loopback interface on Cisco Router with commands as under:

Router1(config)#interface loopback 1
Router1(config-if)#ip address 127.2.0.1 255.0.0.0
Router1(config-if)#no shutdown

Router1(config)#interface loopback 2
Router1(config-if)#ip address 127.3.0.2 255.0.0.0
Router1(config-if)#no shutdown

How to disable or stop a Router Interface?

You can start or stop any Cisco router interface by using the commands “shutdown” to disable the interface and “no shutdown” to enable any interface.

How to Configure IPV6 interface on Cisco Router?

For configuring an IPv6 address on Cisco router, you need to enable it as it is not enable on Cisco Router by-default. You can enable IPV6 using command “ipv6 unicast-routing“.   An IPV6 interface on Cisco Router can be configured with following commands:

Router1(config)#ipv6 unicast-routing
Router1(config)#int fa0/0
Router1(config-if)#ipv6 address 2001:0BB9:AABB:1234::/64 eui-64

How to save Cisco Router Configurations?

You can save the configuration on Cisco router by using the following command in privilege mode:

Router#copy run start

or Simply use Router#write

Backup Cisco Router Configuration:

You can save the configuration of cisco router to local device using the TFTP server. Following cisco commands will do the task for you.

Router2#copy running-config tftp
Address or name of remote host []? 192.168.2.11
Destination filename [Router2-confg]? backup_of-my_router
!!
1030 bytes copied in 3.58 secs (415 bytes/sec)
Router2# 

For more detail on Taking backup and restore with TFTP server you can visit here.

What is default Gateway and how to configure it on Cisco?

The purpose of default gateway is to direct packets addressed to networks not found in the routing-table. In presence of default routes all packets with the unknown destinations are forwarded to default gateway. Default gateways help in limiting system resources like memory, broadcast & processing power.

You can use these cisco commands for configuring default Gateway:

Router2(config)#ip default-gateway 172.16.1.13 

Router2(config)#ip default-gateway 172.16.1.13 

or

Router2(config)# ip route 0.0.0.0 0.0.0. 172.16.1.13

All above commands will set the cisco router default gateway to 172.16.1.13, you can use any one of these commands.

Cisco Router Configuration DHCP Server   

The DHCP server is used for automatic assignments of IP address to hosts. A DHCP server have a pool of IPs and assigns one of them to the every DHCP client. You can configure a Cisco router as a DHCP server by using these commands:

R1(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10
R1(config)#ip dhcp pool W7_DHCP_Pool
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#dns-server 192.168.10.1

Exclude-address command will define the  range of IP address which will not be assigned to hosts. W7_DHCP_Pool is name of DHCP pool, you can use any other. Ans network command will define the IP address which are assigned by DHCP server to DHCP clients.

How to configure DNS Server on Cisco router:

They main purpose of DNS to resolve IP address into domain name and voice versa. DNS maintain a directory of Fully Qualified Domain Names and translate them to IPs. DNS makes Domain names easy for people to remember. You can configure DNS on Cisco by help of following commads:

R1# configure terminal
R1(config)# ip dns server
R1(config)# ip domain-lookup
R1(config)# ip name-server 4.2.2.2
R1(config)# ip host fileserver 192.168.0.5

Advanced Cisco Router Configuration

Now we will see some advance Cisco router configuration examples:

Access list Cisco Router configuration

With ACL you can apply different restrictions and can assign different permission for data packet. For example you can deny or permit a network to enter or out from an interface. There are two main types of ACL

  1. Standard ACL range is from 1-99
  2. Extened ACL range 100–199 and 2000–2699

For configuration example of Cisco ACL, you can visit here.

What is NAT and how to config it on Cisco?

NAT (Network Address Translation) is used to provide Internet_access to the local LAN‘s hosts. NAT uses one or more local IP-address and translated this into Global IP address and vice versa. In Cisco we configured NAT (Network Address Translation) on Border or edge router, on one side of router we have internal LAN network and on other side we have ISP network. There are three types of Network Address Translation:

  1. Static NAT
  2. Dynamic NAT
  3. PAT

You can configure NAT on Cisco router by following steps:

  • Configure a ACL to Allow the IP addresses for internet access
  • Define a NAT pool
  • Apply the ACL on Interface

R1(config)#access-list 1 permit 192.168.22.0 0.0.0.255
R1(config)#ip nat pool NAT-POOL 155.55.55.1 155.55.55.7 netmask 255.255.255.240
R1(config)#ip nat inside source list 1 pool NAT_POOL_IPs
R1(config)#int fa0/0
R1(config-if)#ip nat inside

You can configure Network Address Translation on Cisco Router by using this Tutorial.

Configuration of  inter-vlan routing on Cisco

Vlan are used to create different virtual LAN under the same switch, which creates different broadcast-domains. Host under the one VLAN cant communicate with other VLANs. You require a router if you want to interconnect VLANs with each other. This concept is known as “inter-vlan routing” or“router on a stick”. If you want to learn about the configurations of “inter-vlan routing” on cisco Router, click here.

RIP Cisco router Configuration:

The RIP (Routing Information Protocol) is one of easiest protocol to configure on Cisco Router. RIP is distance vector routing protocol and support maximum 15 hub counts. RIP is used for small scale networksRIP also supports equal cast load balancing for dividing the load across the different interfaces. On Cisco Router you can enable the Routing Information Protocol by following commands:

R1(config)#router rip
R1(config-router)#network 10.1.1.0
R1(config-router)#network 11.1.1.0

With the network command you can define which connected network you want to advertise in RIP. For example if we have two network on R1 10.1.1.0 & 11.1.1.0, and want to advertise into RIP. In this case you can do so by using the above commands.

EIGRP configuration on Cisco Router:

Enhanced Interior Gateway Routing Protocol is designed by Cisco and it is a routing protocol which you can use only on Cisco Router. Configuration of EIGRP on Cisco Router is resembles With RIP. Commands are almost similar to RIP.  Following few commands are required for basic configuration of  Enhanced Interior Gateway Routing Protocol.

Router(config)# router eigrp <Number>
Router(config-router)# network <Subnet or Network-ID>

You can use EIGRP with other routing protocols in same network. This concept is know as redistribution of routing protocols into EIGRP.

OSPF configuration on Cisco Router:

OSPF (Open Shortest Path First ) is the one of the famous and most used routing protocol. It is open standard protocol and you can used it on very vendor’s router. OSPF is link state routing protocol, by using its algorithm Open Shortest Path First can find it best path more accurately.   An example of OSPF configuration on Cisco is as under:

R2#conf t
R3(config)#router ospf 1
R3(config-router)#network 1 7 2.16.10.0 0.0.0.255 area 0
R3(config-router)#network 10 .10.22.0 0 .0.0.255 area 0

Cisco port forwarding

IS IS Configuration on Cisco Router

IS-IS is stands for Intermediate System To Intermediate System. IS IS is a link-state routing protocol and more efficient in case of handling router memory. Configuration of IS-IS is a little tricky as compare to configuration of other routing protocol. Here are example command example:

R1(config-if)# router isis
R1(config-router)# net 49. 0020. 3333.3333.3333.00
R1(config-router)# is-type level-2-only
R1(config-router)# summary-address 11.0.0.0 255.255.0.0 level-1-2

For Complete configuration of IS-IS on Cisco, you can visit here.

Cisco PPPOE Configuration On Router 

The Point-to-Point Protocol over Ethernet PPPoe is Protocol used for configuring a path between the LAN users to ISP network. PPPoe is used to provide the DSL internet access to LAN users.

Client side PPPoe configuration is quite simple.

  • Create a dialer_interface for PPPoE connection
  • Tie it to a physical interface

dialer interface use these configuration commands on Cisco:

R1(config)# interface dialer_new
R1(config-if)# dialer pool 1
R1(config-if)# encapsulation ppp
R1(config-if)# ip address negotiated
The line ip address negotiated instructs the client to use an IP address provided by the PPPoE server.

R1(config-if)# mtu 1492

Tie it to a physical interface: In 2nd step we assign our ISP facing  physical interface to our newly created PPPoE dialer group:

R1(config)# interface f0/0
R1(config-if)# no ip address
R1(config-if)# pppoe-client dial-pool-number 1
R1(config-if)# no shutdown

Configure Cisco Router as NTP Server

With an NTP server you can synchronize time setting on every Cisco device in the network.  The NTP server is important, because different protocol configurations required the same time on all the network devices. After that you have set the NTP server, all the client devices can get the updated time setting from FTP server. Few commands are required for basic configurations of NTP server on Cisco:

NTP_client(config)#ntp server 172.16.1.11
NTP_Server(config)#ntp master

MPLS Configuration On Cisco router 

The M PLS stands for Multiprotocol Label Switching and it is a routing technique for fast forwarding of data packets. MPLS is a very detail and large topic and i am sharing here a an example of MPLS VPNs on Cisco Routers. For more detail you can explore more on search engine.

HTTP Configuration on Cisco Router 

You can enable the HTTP on Cisco router with following ip commands.

R1(config)#aaa new-model
R1(config)#aaa authentication login default local
R1(config)#username test secret testpass
R1(config)#ip http authentication local
R1(config)#ip http secure-server

Cisco router configure HSRP:

The HSRP Hot Standby Router Protocol  is designed by Cisco and it redundancy protocol used for handling different Gateways. The main purpose of HSRP is to keep  a link up with ISP., In case of failure of one link.

SSH Configuration on Cisco

The SSH is used for creating a secure connection from remote host.

  • Set console and enable password on Cisco Router
  • Generate the RSA Keys and Line VTY configurations
  • Username & password for SSH

Here is an example of SSH configuration on Cisco, you can read it here.

Cisco GUI Configurations

If you think that CLI commands are difficult to remember for configuration of Cisco router. There are tools like Cisco SDM and “Cisco Network Assistant” is available, using these tools you can configure Cisco router with using any command. For example you can visit how to configure Cisco Router with SDM GUI tool.

In conclusion, I have tried to cover some important topics related to Cisco configurations,if you want to learn more about the CISCO configuration CLI Commands, you can visit here.  For Basic Switch Configuration on Cisco Visit here.

Using this configuration guide you can configue any Ciso IOS router like Cisco 1800 series,1841, cisco 1905 k9, 1941 k9, cisco 2900 series, cisco 800 series, cisco 800 series, cisco 881-k9, cisco asr 1001-x router, cisco ios xrv 9000 etc

Please share this if you like it. Thank you..!

Advanced  BGP Interview Questions

About Waqas Azam

My name is Waqas Azam and I am a professional blogger & freelance writer. I also working in the IT industry for over 7 years.I graduated in 2010 in Computer Science and information technology.

View all posts by Waqas Azam →

One Comment on “Complete Guide on Cisco Router Configuration | Beginners Tutorial”

Leave a Reply

Your email address will not be published. Required fields are marked *